Copy and Paste between applications



Release:

4.6  •  5.0  •  5.1  •  5.2

You can use the standard Copy and Paste commands from the Edit menu or the equivalent keyboard shortcuts, Ctrl+v and Ctrl+c, in most situations you would expect.

Copy and Paste tabular data

Copy cell(s) from an Analytica Result or Edit table

  1. Open the window containing the table.
  2. Select a cell, or rectangular range of cells.
  3. Select Copy from the Edit menu or press Control+c.
  4. Select the top-left cell (or a cell-range of the same size as you copied) in the same or another table in Analytica or in another table-based application, such as Microsoft Excel.
  5. Select Paste from the Edit menu or press Control+v.

Copy All the Elements of a Table in Addition to the Index Elements

If you want to copy an entire table, including row and column headers, and all slices if it has more than two dimension:

  1. Select Copy Table from the Edit menu.

You can paste this into another table-based application, like Microsoft Excel.

Copy and Paste Data from a Spreadsheet into Analytica

This is almost the same as copying data within or between spreadsheets:

  1. Select a group of cells in a spreadsheet.
  2. Select Copy from that program’s Edit menu (Control+c) to copy the data to the clipboard.
  3. Bring the Analytica model to the front and open the Edit Table window you want to paste the data into.
  4. Select a top-left cell or the same number of cells that you originally copied.
  5. Select Paste from the Edit menu (Control+v)
Tip
You may need to pivot the Analytica table first to make sure the rows and columns are arranged in the same way as the original table. When copying a row of data from a spreadsheet into a one-dimensional table, transpose the data first so that you are copying it as a column of cells, not a row of cells.

Paste Data from Another Application

To paste data from a program other than a spreadsheet:

  • Use tab characters to separate items, and return characters to separate lines.
  • It accepts numbers in most common formats, including exponential, currency symbols and commas separate thousands. You can use the suffixes that Analytica recognizes, including K, or M.

Quoted values

When pasting data into tables or fields within Analytica, quotations are sometimes added around content. The general rule for when quotations are added is this:

  • Quotes are added to content when the source of content is not a field that holds Analytica expressions, but the source expects an expression.

The rule has the effect that when you evaluate the target, the result has the same value as the source data. Some consequences of this rule are

  • When pasting from a Definition to a Definition, quotes are neither added nor removed.
  • When pasting from a Description (which is not an expression) to a Definition, quotes are added. The result of evaluating the variable is then the same as the Description text.
  • When pasting from an external text editor into a Definition, quotes are added.
  • When pasting from an external text editor into a Description field, quotes are not added.

You may encounter cases where you didn't want the quotes to be added for you. When this happens, select the table cells and select Remove quotes when possible from the right-mouse context menu.

Copy and Paste Diagrams and Graphs

Copy Nodes from a Diagram

  1. Select a node or group of nodes from a Diagram (in Browse or Edit mode).
  2. Select Copy from the Edit menu or press Control+c.
  3. Click a location in the same or another Analytica Diagram or in another application, for example a Microsoft Word document, and Select Paste from the Edit menu or press Control+v.

If you paste the results into an Analytica diagram window (the original diagram or another), it creates new nodes into that diagram with their underlying variables or other objects. It adds a digit to each identifier to distinguish them from the original objects that you copied. It retains any influence relationships among the objects. If you past a module node, it copies all objects inside that module (and any submodules recursively).

If you paste copied nodes into another application, like Microsoft Word, Power Point, or Excel, it pastes a picture of the nodes and any influence arrows.

Copy an Entire Influence Diagram

With a Diagram window active, select Copy Diagram from the Edit menu. It copies the influence diagram as a picture but not the objects that the nodes represent.

Copy a Result Graph

This is useful if you want to create a document or presentation using graphs from an Analytica model:

  1. Open a Result window showing the graph.
  2. Select Copy from the Edit menu or Control+c
  3. Click a location in the document of another application, such as Microsoft Word or Powerpoint.
  4. Select Paste from the Edit menu or press Control+v.

This pastes a picture of the graph into the document.

Export Diagram or Graph to image file

For greater flexibility, you can use the Export' from the File menu to export a Diagram or Graph into an image file. In each case, it prompts you for the desired image format, including EMF, PNG, JPEG, BMP, and TIFF.

Export Diagram as an Image File

  1. With the diagram showing, select Export from the File menu.
  2. From the Save dialog, select the desired format.

It stores an image of the full diagram (not just the selected nodes).

Export a Result Graph as an Image File

  1. Open the Result window containing the graph.
  2. Select Export from the File menu and select the desired image file format.

See Also


Comments


You are not allowed to post comments.