Difference between revisions of "User Input nodes"

m (Update to match User Output updates)
 
Line 38: Line 38:
 
# Make sure you are in [[edit mode]].
 
# Make sure you are in [[edit mode]].
 
# Select the variable.
 
# Select the variable.
# Select '''Make Input Node '''from the [[Object menu]]. The input node appears in the same diagram next to the selected node.
+
# There are three options once you have selected the node:
 +
#* Select '''Make Input Node '''from the [[Object menu]]
 +
#* Right click the node and select '''Make User Input Node'''
 +
#* Use the keyboard shortcut ''Ctrl+Alt+I''
 
# Move the input node to the location you want.
 
# Move the input node to the location you want.
 
# Adjust the size of the node.
 
# Adjust the size of the node.

Latest revision as of 21:23, 12 August 2019



Release:

4.6  •  5.0  •  5.1  •  5.2

An input node lets you, or your end user, see and easily change the value of a variable directly in the diagram, without opening an Attribute view or Object window (see Browsing with input and output nodes). In browse mode you can change only the values and definitions of input nodes.

An input node is an alias of a variable that you want to treat as an input to the model (see Alias nodes).

The type of definition of the original variable determines the appearance of the input node. If you want your users to be able to change the type of definition, instruct them on how to open an Attribute view or Object window and use the expr menu.

Input field

Chapter9 2.png A single number or text value (scalar) displays as an input field. You can have Analytica check if the input value is acceptable by using the Check attribute; the check is performed on input of a new value. After creating the input field, you should select Number only, Text only or Number or text only from the Definition type pulldown in the Attribute panel or Object Window if you want to disallow the entry of general expressions.

Checkbox

Checkbox.png A true/false or yes/no selection.

Input popup menu

Chapter9 3.png A choice displays as an input popup menu. To create an input menu for an input node, see Creating a choice menu.

List

Chapter9 4.png A list or list of labels displays as a List button. See Creating an index.

Edit table

Chapter9 5.png An edit table displays as an Edit Table button. See Defining a variable as an edit table.

Probability distribution

Chapter9 6.png A probability distribution displays a button with the name of the distribution. See Defining a variable as a distribution.

Creating an input node: To create an input node from a variable:

  1. Make sure you are in edit mode.
  2. Select the variable.
  3. There are three options once you have selected the node:
    • Select Make Input Node from the Object menu
    • Right click the node and select Make User Input Node
    • Use the keyboard shortcut Ctrl+Alt+I
  4. Move the input node to the location you want.
  5. Adjust the size of the node.
Tip
To make several input nodes at once, select the nodes and then choose Make Input Node.

See Also


Comments


You are not allowed to post comments.